AWS Outage Impacting the BSN Portal

Incident Report for Breach Secure Now

Resolved

The AWS outage that affected the BSN portal and related services has been resolved. Thank you for your patience during this incident.
Posted Oct 27, 2025 - 09:54 EDT

Monitoring

The BSN portal is hosted on AWS, which experienced an outage between approximately 4:00 AM and 6:00 AM EST. As a result, the BSN portal and related services, including welcome and notification emails, were temporarily affected.

AWS has implemented mitigation measures and is progressing toward full recovery. We are observing continued improvement across the BSN portal and affected systems. Our team will continue to monitor the situation closely to ensure full restoration and stability.
Posted Oct 20, 2025 - 10:58 EDT
This incident affected: Amazon Web Services (AWS).