Update: A fix has been developed and deployed to both the Microsoft Teams Application and Catch Phish.
Notes: An error occurred when decoding certain security tokens from Microsoft.
Thank you for your patience and understanding as we resolved the issue.
Posted Nov 06, 2025 - 16:01 EST
Update
Update: A fix has been developed and is currently being tested. We will provide an update once the fix has passed QA and deployed to production. Thank you again for your patience and understanding as we resolve this issue.
Posted Nov 05, 2025 - 15:39 EST
Identified
We have identified an issue preventing some users from accessing Catch Phish and the BSN Microsoft Teams app on desktop. Affected users may see an error message stating that their email address is not recognized. These issues appear to be isolated to desktop applications.
Our team has identified the issue and is working on a fix. We will provide updates as soon as more information becomes available. Thank you for your patience and understanding as we work toward resolving this issue.
Posted Nov 04, 2025 - 12:38 EST
This incident affected: Integrations and Catch Phish.