Microsoft Service Outage May Impact Breach Secure Now

Incident Report for Breach Secure Now

Resolved

The outage affecting several Microsoft services has been resolved. There should be no further impact to the Breach Secure Now portal. Thank you for your patience while we monitored this issue.
Posted Oct 31, 2025 - 11:00 EDT

Monitoring

Microsoft is currently experiencing an outage affecting several of its services. Since the BSN platform integrates with Microsoft, certain features such as Single Sign-On (SSO), Active Directory (AD) Sync, Direct Mail Delivery, Catch Phish, and Microsoft Teams may be impacted.

Our team is actively monitoring the BSN platform and will provide updates if conditions change or issues are identified.

Microsoft is currently in the process of implementing a fix. If you are experiencing issues with the BSN platform after Microsoft services have been restored, please open a support ticket.

Thank you for your patience and understanding.
Posted Oct 29, 2025 - 17:13 EDT
This incident affected: Portal Stability.