Issue Saving Domains for Dark Web Monitoring

Incident Report for Breach Secure Now

Resolved

The issue preventing domains from being saved for Dark Web Monitoring has been fully resolved. Thank you for your patience while we worked to address this.
Posted May 23, 2025 - 10:12 EDT

Monitoring

The issue preventing domains from being saved for Dark Web Monitoring has been resolved. Our engineering team will continue to monitor to ensure the feature remains fully operational. Thank you for your patience while we worked to address this.
Posted May 21, 2025 - 17:53 EDT

Investigating

We are currently investigating an issue affecting domain submissions for Dark Web Monitoring. Partners are able to add domains, but upon clicking "Save," an error message appears stating: "Failed to create client task."

Our team is actively working to identify the root cause and will share updates as more information becomes available. Thank you for your patience.
Posted May 21, 2025 - 16:59 EDT
This incident affected: Dark Web Monitoring.