SRA Questionnaire Loading Issue
Incident Report for Breach Secure Now
Resolved
This incident has been resolved. We appreciate your patience and support as we addressed this matter.
Posted Nov 05, 2024 - 09:19 EST
Monitoring
A fix has been successfully implemented, and the SRA Questionnaire page appears to be fully operational. We will continue to monitor the issue moving forward.
Posted Nov 01, 2024 - 10:22 EDT
Identified
The SRA Questionnaire page is not loading for some users. The issue has been identified and a fix is being implemented. Thank you for your patience.
Posted Nov 01, 2024 - 08:58 EDT
This incident affected: Security/HIPAA Risk Assessments.