User Profile Updates & User Creation Issue

Incident Report for Breach Secure Now

Resolved

This incident has been resolved.
Posted Apr 08, 2026 - 21:24 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 08, 2026 - 15:20 EDT

Investigating

We are currently investigating an issue affecting user management within the platform.

What’s happening:
At this time, users may experience issues when attempting to:

Save changes to existing user profiles
Create new users manually

In some cases, selecting “Save” may not complete the action as expected.

Scope:
This issue may impact all user types across the platform.

Our team is actively working to identify the root cause and implement a resolution as quickly as possible. We will continue to provide updates as more information becomes available.

Thank you for your patience and understanding.
Posted Apr 08, 2026 - 12:22 EDT
This incident affected: User Management.