Homepage and Partner Resources Page Outage

Incident Report for Breach Secure Now

Resolved

The issue affecting the Breach Secure Now homepage (www.breachsecurenow.com) and our Partner Resources page, which hosts our marketing content, has been resolved. Both pages are now fully operational. Thank you for your patience during this downtime.
Posted Jun 19, 2024 - 12:43 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 19, 2024 - 12:00 EDT

Investigating

The Breach Secure Now homepage (www.breachsecurenow.com) and our Partner Resources page, which hosts our marketing content, are currently unavailable. We are actively investigating the issue and will provide updates as soon as possible. Thank you for your patience.
Posted Jun 19, 2024 - 10:06 EDT
This incident affected: Marketing Resources.