Google Cybersecurity Training Issue

Incident Report for Breach Secure Now

Resolved

The issue with accessing the Google Cybersecurity Training from the “Improve your ESS” section on the Dashboard has been resolved. Thank you for your patience as we addressed this matter.
Posted May 06, 2025 - 16:44 EDT

Identified

We’ve identified an issue with the Google Cybersecurity Training not loading correctly through the "Go" button in the “Improve your ESS” section of the Dashboard. The training is still accessible through the Training tab. Our team has determined the cause of the issue and is actively working on a permanent fix.
Posted May 02, 2025 - 12:06 EDT
This incident affected: Training.