Issue Downloading Reports and Certificates

Incident Report for Breach Secure Now

Resolved

The issue affecting the downloading of reports and certificates has been resolved. Thank you for your patience as we addressed this matter.
Posted Sep 05, 2025 - 13:55 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 02, 2025 - 10:55 EDT

Identified

We have identified an issue affecting the downloading of reports and certificates from our platform. Our engineers have confirmed the problem and are actively investigating the root cause. We will provide an update as soon as more information becomes available. We apologize for any inconvenience this may cause and appreciate your patience.
Posted Sep 02, 2025 - 10:02 EDT
This incident affected: Reporting.