At this time, AWS has formally concluded this incident. We have verified that our platform is operating at full capacity and appreciate your support as we monitored this situation.
Posted Oct 24, 2023 - 12:51 EDT
Monitoring
Currently, AWS is not reporting any errors, and our platform appears to be fully operational. We will continue to monitor the situation to ensure the ongoing operational status of our platform.
Posted Oct 24, 2023 - 12:07 EDT
Investigating
At 10:45 AM EST, we received notifications indicating that some users may encounter challenges while attempting to log into the platform. Our team has identified the root cause as operational issues within "Identity Services" on AWS, where our platform is hosted. Currently, AWS is not reporting any errors, and our platform appears to be fully operational. We will continue to monitor the situation to ensure the ongoing operational status of our platform.