Simulated Phishing Delivery Issue in Google Workspace and Gmail

Incident Report for Breach Secure Now

Resolved

We have implemented a permanent fix that addresses the phishing campaign scheduling issue. Our Support team is following up with partners who have open tickets related to this matter and will continue monitoring phishing campaign performance to ensure stability.
Posted Oct 03, 2025 - 13:51 EDT

Identified

We are currently experiencing issues with simulated phishing emails not being delivered to Google Workspace and Gmail accounts. This may be due to an increased volume of simulated phishing emails being sent to Google-hosted accounts.

Google is currently blocking delivery. Our team is actively working with Google to resolve this matter. We will provide updates as soon as more information becomes available. Thank you for your patience.
Posted Sep 19, 2025 - 11:40 EDT
This incident affected: Simulated Phishing.