Dark Web Tab Issue
Incident Report for Breach Secure Now
Resolved
A fix has been implemented for the issue affecting the Dark Web tab. The tab is now fully operational. Thank you for your patience as we investigated this issue.
Posted Oct 10, 2024 - 16:21 EDT
Identified
We have identified an issue related to the Dark Web tab in the portal. Users are encountering an error message when trying to access the tab, and the buttons for adding domains are missing. Our team is actively working to resolve this issue and will share further details as soon as they are available. Thank you for your patience.
Posted Oct 10, 2024 - 11:42 EDT
This incident affected: Dark Web Monitoring.